Difference between revisions of "HOWTO: Install Himerge"

From Sabayon Wiki
Jump to: navigation, search
m (advanced user warning)
 
(Marked as outdated)
 
Line 1: Line 1:
 +
{{Warning| ''The following article is outdated! Please be careful when using it!''}}
 
[[Image:himerge.png|right|190px]]
 
[[Image:himerge.png|right|190px]]
 
{{Warning| '''Portage (emerge) is not the primary package manager for Sabayon, this article is for advanced users only. In other words if this fails for you, its your fault. You have been warned.'''}}
 
{{Warning| '''Portage (emerge) is not the primary package manager for Sabayon, this article is for advanced users only. In other words if this fails for you, its your fault. You have been warned.'''}}

Latest revision as of 22:53, 1 December 2012

Stop.png
The following article is outdated! Please be careful when using it!
Himerge.png
Stop.png
Portage (emerge) is not the primary package manager for Sabayon, this article is for advanced users only. In other words if this fails for you, its your fault. You have been warned.

Himerge is a graphical user interface for emerge (Gentoo's Portage system) written in Haskell using gtk2hs.

The main idea is to simplify browsing the entire portage tree as well as of running the most basic and common options from the emerge command. Himerge also offers several handy tools, like global and local use flags browsers, pretty much inspired on UFED (Gentoo Linux USE flags editor). It also uses eix (Small utility for searching ebuilds with indexing for fast results) as a back-end command to show package information on html/css format, so you can access the package web-site for a quick-glance.


As of the latest himerge version, you need the following packages in order to compile and install himerge:

  • ghc >= 6.6 NOTE as of Jan.15,2008 only 6.6.1 is working, 6.8.x isn't working, but an update is expected soon
  • gtk2hs >= 0.9.12 or its darcs version with mozembed support enable
  • eix (any version should work, but the latest one is the more recommended)
  • gentoolkit >= 0.2.3
  • portage-utils >= 0.1.28
  • cabal (any version should work, but the latest one is the more recommended)


 # emerge --sync


 # emerge -av himerge

Please see himerge site for more info. The dev is thinking about dropping the ebuild so only way to install will be to manually do it. You can emerge darcs and get the latest darcs version and than read the readme file