From Sabayon Wiki
Revision as of 12:43, 31 January 2012 by Yokmp (Talk | contribs) (marked for deletion)

(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to: navigation, search
This page has been proposed for deletion because it does not meet the Editing Guidelines.
If you disagree, please discuss it here.

Upgrading D-Bus


After upgrading dbus most users run into the error of dependencies being broke , to fix this problem you have to create symlinks to the new shared object libraries (the .so files). These are specific to SL 3.2*


emerge dbus-glib
emerge dbus-qt3-old
ln -s /usr/lib/libdbus-1.so.3.2.0 /usr/lib/libdbus-1.so.1
ln -s /usr/lib/libdbus-glib-1.so /usr/lib/libdbus-glib-1.so.1
ln -s /usr/lib/libdbus-qt-1.so /usr/lib/libdbus-qt-1.so.1
emerge gentoolkit
revdep-rebuild -X

Remember to remove the symlinks when revdep-rebuild is finished. Also see posts and instructions on the forums.